Setting Mikrotik Load Balance 2 ISP Atau Lebih

Setting Mikrotik Load Balance 2 ISP Atau Lebih

Halo teman-teman satria mahir, pada kesempatan kali ini saya mau menulis artikel tentang setting mikrotik load balance 2 isp atau lebih.

Load balancing ialah suatu teknik yang dimanfaatkan buat membagi traffic lewat 2 atau lebih jurusan koneksi dengan cara seimbang dan merata, maksud dari load balancing yakni utk memaksimalkan throughput, mengurangi respone time, dan juga menghindari overload atau penumpukan traffic pada salah satu trayek koneksi (link) yang dapat menyebabkan koneksi jadi down.

Syarat buat mengkonfigurasi load balancing pada router yakni mesti memiliki 2 atau lebih jurusan koneksi (link) buat menuju ke network lain, contohnya saja router yang membuka ke jaringan internet lewat sekian banyak ISP (Internet Service Provider).

Sederhananya, load balancing merupakan cara yang bisa diterapkan kalau anda berlangganan internet lewat 2 ISP yang Berlainan, tapi mengharapkan biar koneksi internet dari ke-2 ISP tersebut masuk ke dalam satu router yang sama.

Contohnya anda berlangganan internet dari ISP A dan ISP B masing-masing se gede 5 Mbps. Lalu anda ingin biar keduanya aktif dengan cara bersamaan guna mengurangi penumpukan traffic yang ada di jaringan lokal, dalam kondisi seperti ini anda bisa memakai load balancing sebagai solusinya.

Setting Mikrotik Load Balance 2 ISP Atau Lebih Dengan Metode PCC

Pada anjuran ini saya akan membagikan langkah-langkah cara mengkonfigurasi load balancing pada router mikrotik metode PCC dengan memanfaatkan 2 link ISP, bandwidth yang dimanfaatkan merupakan masing-masing se besar 5Mbps. Berikut topologi yang saya gunakan.

Kondisi dari topologi di atas merupakan sebagai berikut :
  1. Router yang dimanfaatkan yakni kategori RB951Ui-2HnD
  2. Interface ether1 membuka ke ISP-1
  3. Interface ether2 membuka ke ISP-2
  4. Interface ether3 membuka ke switch sebagai gateway buat jaringan lokal

Seandainya kondisi di jaringan anda tidak sama, silakan disesuaikan saja ya, sekarang saatnya kita konfig load balance-nya, buka New Terminal mikrotik setelah itu paste script-script di bawah ini.

#1. Tambahkan Konfigurasi IP address

Perdana, kita tambahkan alamat IP pada masing-masing interface router, merupakan ether1 dan ether2 buat WAN, sedangkan ether3 buat LAN.

/ip address
add address=192.168.90.2/30 comment=ISP-1 interface=ether1 network=192.168.90.0
add address=192.168.91.2/30 comment=ISP-2 interface=ether2 network=192.168.91.0
add address=192.168.1.1/24 comment="Local Network" interface=ether3 network=192.168.1.0

#2. Konfigurasi DNS Resolver

Ke-2, tambahkan konfigurasi DNS, tujuannya supaya router dapat menjangkau seluruhnya alamat domain yang ada di internet. Tanpa konfigurasi DNS sehingga router hanya bisa menjangkau alamat IP saja (Gak bisa internetan).

/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4

#3. Konfigurasi Mangle Utk PCC

Ke-3, tambahkan konfigurasi mangle utk menandai tiap-tiap koneksi yang masuk ke dalam router lewat interface ether1 dan ether2, ini ditentukan dari chain yang digunakan yakni input dan juga action mark connection.

/ip firewall mangle
add action=mark-connection chain=input connection-state=new in-interface=ether1 new-connection-mark=ISP-1 passthrough=yes
add action=mark-connection chain=input connection-state=new in-interface=ether2 new-connection-mark=ISP-2 passthrough=yes

Rule mangle di atas akan menandai koneksi yang masuk dari ether1 sebagai connection-mark=ISP-1, dan koneksi yang masuk lewat ether2 akan ditandai sebagai connection-mark=ISP-2, dari situ kita bisa memetakan koneksi yang ke luar (chain output) dari router lewat masing-masing interface dengan action mark-routing.

add action=mark-routing chain=output connection-mark=ISP-1 new-routing-mark=Jalur-1 passthrough=no
add action=mark-routing chain=output connection-mark=ISP-2 new-routing-mark=Jalur-2 passthrough=no

Nah ini yang paling penting dari load balancing metode PCC, PCC (Per Connection Classifier) ialah satu buah feature pada router mikrotik buat melakukan tracking koneksi yang masuk ataupun ke luar melintasi router berdasarkan kriteria tertentu.

Metode PCC yang akan kita gunakan kali ini yakni utk mengklasifikasikan koneksi yang berasal dari interface lokal (ether3) berdasarkan address and port.

add action=mark-connection chain=prerouting dst-address-type=!local in-interface=ether3 new-connection-mark=ISP-1 passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=ether3 new-connection-mark=ISP-2 passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/1

Seterusnya petakan koneksi yang berasal dari interface lokal (ether3) yang akan ke luar meninggalkan router lewat masing-masing interface WAN yakni ether1 dan ether2.

add action=mark-routing chain=prerouting connection-mark=ISP-1 in-interface=ether3 new-routing-mark=Jalur-1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=ISP-2 in-interface=ether3 new-routing-mark=Jalur-2 passthrough=yes

#4. Tambahkan Rule NAT Buat Client

Biar client yang berada di bawah router dapat mengakses ke jaringan internet, sehingga kita mesti meneruskan network address translation (NAT) masquerade.

/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat out-interface=ether2

#5. Tambahkan Entri Routing

Entri routing yang mesti kita input ke dalam table routing terbagi jadi 2 kategori entri routing. Mula-mula, ialah buat tentukan apakah satu buah koneksi mesti lewat jurusan ISP-1 atau lewat rute ISP-2.

Parameter routing-mark ini adalah routing-mark yang sudah kita buat diawal mulanya pada mangle.

/ip route
add check-gateway=ping distance=1 gateway=192.168.90.1 routing-mark=Jalur-1
add check-gateway=ping distance=2 gateway=192.168.91.1 routing-mark=Jalur-2

Ke-2, yakni berfungsi sebagai skema failover jika salah satu link mengalami ganjalan (down), sehingga seluruhnya traffic akan dialihkan ke link yang masih aktif.

add distance=1 gateway=192.168.90.1
add distance=2 gateway=192.168.91.1

Sampai disini konfigurasi load balancing metode PCC sudah selesai, dampak load balancing rata-rata baru terasa seandainya traffic di jaringan lokal sudah mengalami peningkatan (full traffic), utk menentukan load balancing sudah berfungsi dengan baik atau belum, anda bisa mengeceknya di menu Interfaces.

Catatan :

  1. Loadbalancing memakai teknik pcc ini akan berlangsung efektif dan jelang seimbang seandainya semakin banyak koneksi (dari client) yang terjadi.
  2. Gunakan ISP yang memiliki bandwith FIX bukan Sharing buat memperoleh hasil yang lebih optimal.
  3. Load Balance memakai PCC ini bukan selamanya dan sepenuhnya satu buah solusi yang tentu berhasil baik di seluruhnya kategori network, karena proses penyeimbangan dari traffic yaitu berdasarkan logika probabilitas.

Demikianlah artikel kali ini mengenai Setting Mikrotik Load Balance 2 ISP Atau Lebih, semoga artikelnya bermanfaat dan terima kasih.